3rd party payment provider issue causing possible delays on order activation.

Incident Report for Natlink

Resolved

Possible delay has now been resolved by service provider.

Thank you for your patience
Posted Sep 19, 2025 - 11:45 UTC

Monitoring

We're monitoring the activation of incoming orders, affected order amount is minimal.

Thank you for your patience.
Posted Sep 19, 2025 - 11:01 UTC

Identified

We are currently experiencing possible delays on subscription activation due to a 3rd party payment issue. Service provider is investigating the issue.
Posted Sep 19, 2025 - 09:46 UTC
This incident affected: Third Party Services (Payment Providers).