Service Disruption Detected

Incident Report for Natlink

Resolved

Location updates from Tracker Artemis, Luna and Bark devices are working normally again.
Posted Sep 12, 2026 - 10:35 CEST

Monitoring

A fix has been applied and location updates from Tracker Artemis, Luna and Bark devices are arriving normally again. We are monitoring to confirm the issue is fully resolved.
Posted Sep 12, 2026 - 09:03 CEST

Identified

We have identified the cause of the delayed location updates and a fix is being applied. Artemis, Luna and Bark devices are affected.
Posted Sep 12, 2026 - 09:01 CEST

Update

Location updates from Tracker Artemis devices are arriving in the app with a delay.

We are investigating and will post an update as soon as we know more.
Posted Sep 12, 2026 - 08:51 CEST

Investigating

We're currently investigating a potential issue affecting some users. You may experience delays or errors when accessing our service. Our engineering team is actively working to identify the cause. We will provide an update as soon as more information becomes available.
Posted Sep 12, 2026 - 08:28 CEST
This incident affected: Location (Tracking Service).