This incident is now resolved. A configuration issue caused some devices to be displayed incorrectly in the app, showing them as requiring an upgrade when the customer's existing subscription already covered them. Based on the reports we received, the issue started at around 14:30 UCT. The fix has been applied on our side and no app update is needed. Device tracking and positioning were not affected at any point.
If you still see anything unexpected in your device list after restarting the app, please contact our support team via https://support.wehuntapp.com.
Posted Sep 08, 2026 - 18:47 UTC
Monitoring
The fix has been applied and confirmed working. Devices covered by an active subscription are now displayed correctly again in the app. If you were affected, please restart the app to see the change. We will continue monitoring before closing this incident.
Posted Sep 08, 2026 - 18:37 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 08, 2026 - 18:25 UTC
Update
We are aware that some users are currently seeing a "GPS Max" label on their devices in the app, even when their existing subscription already covers their devices, and are unable to open device details as a result. This does not affect your actual subscription or device tracking, your devices continue to update and report location normally, and this can be verified in the Map view.
Posted Sep 08, 2026 - 18:15 UTC
Investigating
We're currently investigating a potential issue affecting some users. You may experience delays or errors when accessing our service. Our engineering team is actively working to identify the cause. We will provide an update as soon as more information becomes available.
Posted Sep 08, 2026 - 18:07 UTC
This incident affected: Applications (WeHunt Mobile).