Artemis Firmware malfunctional

Incident Report for Natlink

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 13:28 UTC

Update

We will contact customers directly who are expected to have an affected device via SMS. The message will include instructions on how to get a new replacement device as soon as possible.
Posted Sep 23, 2025 - 20:32 UTC

Update

An additional solution for the remaining affected Artemis devices may have been identified and is currently being tested. We will share further updates as soon as testing is complete.
Posted Sep 23, 2025 - 16:45 UTC

Monitoring

A fix has been deployed and most Artemis devices are functioning normally again. However, some units remain affected. Please see this article for instructions on how to proceed:

https://support.tracker.fi/en/support/solutions/articles/151000220149-important-notice-artemis-device-update-issue
Posted Sep 21, 2025 - 10:51 UTC

Identified

The issue has been identified and a fix is already in place for affected users, but it may not resolve every related problem.

Learn more in this support article: https://support.tracker.fi/en/support/solutions/articles/151000220149

You can change the article’s language after opening it.
Posted Sep 20, 2025 - 21:50 UTC

Update

We are continuing to investigate this issue.
Posted Sep 20, 2025 - 15:44 UTC

Investigating

We have identified an issue affecting Artemis devices during a recent update. In certain situations, the device may stop working.

Next steps:
Our engineering team is actively developing a recovery solution for affected devices.
We will publish detailed instructions and provide support options as soon as they are available.

We apologize for the inconvenience and are treating this issue with the highest priority. Updates will be posted on our support page as soon as possible.
Posted Sep 20, 2025 - 15:03 UTC
This incident affected: Device commanding.