Service Disruption Detected

Incident Report for Natlink

Resolved

Issue has been resolved.
Posted Sep 24, 2025 - 08:39 UTC

Monitoring

Operator has issued a fix and we are monitoring the results.

Sorry for the inconvenience.
Posted Sep 23, 2025 - 07:20 UTC

Update

3rd party operator has identified the issue and they are working on implementing a fix.
Posted Sep 22, 2025 - 12:44 UTC

Identified

3rd party operator issue affecting location updates, this issue might affect Artemis, Luna, R10-series and G-series devices.

We're working together with the operator to solve this issue as fast as possible.

Sorry for the inconvenience.
Posted Sep 22, 2025 - 12:27 UTC

Investigating

We're currently investigating a potential issue affecting some users. You may experience delays or errors when accessing our service. Our engineering team is actively working to identify the cause. We will provide an update as soon as more information becomes available.
Posted Sep 22, 2025 - 12:14 UTC
This incident affected: Third Party Services (Network Operators).