Issue with location data from WeHunt GPS/GPS II devices

Incident Report for Natlink

Resolved

Location data from WeHunt GPS and WeHunt GPS II devices is working normally again. Thank you for your patience.
Posted Sep 11, 2026 - 11:16 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 11, 2026 - 10:47 CEST

Investigating

WeHunt GPS and WeHunt GPS II devices are not sending their position to our servers. An affected device may appear offline in the app, or show an old position, even though the device is switched on and working normally.

Other collar models are not affected.

We are investigating and will post an update as soon as we know more.
Posted Sep 11, 2026 - 10:19 CEST
This incident affected: Location (Tracking Service).